Browse Category

Fixes

How to download big files like full site backup from Cpanel and avoid download interruption

How to download big files like full site backup from Cpanel and avoid download interruption? specially in slow connection.

I have been having this problem for a while now until I finally figured out what was cooking. When you generate full site backup in cpanel it keeps the file in home directory of the site.

Since full backups are usually huge for most sites (in my case it was about 1.3 GB) and I right now have only 1.5 Mbps speed I needed a download manager to make sure it utilizes all my allowed download speed. Browser downloads are usually slow. So downloading the file directly from file manager was not a good option. It was slow and if session ended it breaks everything and doesn’t resume from where it left off.

I downloaded internet file manager and it added an extension in firefox so I could download the file using it. But even now I noticed that it didn’t have resume capabilities and still slow!?

Then it got me thinking, how do we download files from the internet from website using these download managers. These files are in public_html (means under certain domain and with a static link).

I moved the file to public_html and wanted to download using the static link example.com/backup.tar.gz guess what it was not working still!?

Then suddenly I thought there must be some kind of file permission problem. I changed file permission to 0644 (possibly could have worked for 0755 as well) and voila! I was able to download it with a static link like example.com/backup.tar.gz  and with full speed. Download manager software was able to make multiple connections and it had resume capabilities 

 

back_upDownload-forbidden and failed

home-directory in linux server

Internet_download_manager_downloading file

 

 

Sublime Text doesn’t support Bangla or Unicode! (Fix/Work around)

So I was excited about this text editor that every one loves. Sublime Text. I downloaded Sublime Text 2 (For some reason I was reading it wrong, I thought it was Subline and only now I found out it was Sublime :/ ). So I started coding some basic stuff. And immediately notice that it doesn’t support Bangla. I basically used google translator to translate my Bangla (Me Lazy! :p , I don’t keep avro and all those stuff installed .. I either translate or type online from various online Bangla typing sites). I found out it was all broken. When I saved and saw it on browser. It was even worse.
Broken Bangla in Sublime Text 2 can't write bangla in subline text 2 browser example

 

 

Then next I thought You can’t write Bangla on HTML (since this was probably the first time I tried it in code), So I opened in Notepad and saved it. It was alright.

Then I tried again in sublime text, It started working in it for some reason.. No Idea way :/ .. I mean the on the editor it’s broken but everything is okay on the browser.

can't write bangla in subline text 2 editor

can't write bangla fixed in notepad save it once here

 

can't write bangla in subline text 2 browser output problem fixed

Weird kind of fix , I know.. I think it will work with all other Unicode Characters.

 

Summary of the fix

  1. Create your html file in sublime text
  2. If you want to use unicode characters (here Bangla Specifically in this tutorial) save the file in note pad once
  3. Get back to sublime text and from now on everything should work normally

How to fix camera problem (Media Server failed. Camera needs restart) on the Samsung Galaxy Grand Prime?

Suddenly I was having this problem. My Samsung Galaxy Grand prime’s phone was not working. I thought maybe the app is not working so lets download another camera app. But that didn’t work too. So I though I’m going to give it a factory reset. But that will make my phone like brand new and I’ll probably need to re-install all my apps and my files might be gone as well. So I thought I’ll do it some other time. Today suddenly I thought to my self why don’t  search the internet.. Silly my I should have done that the first day..  I got the solution and it was just too easy..

  1. Shut down the phone,
  2. Remove the Battery and re-add it.
  3. Start your phone

boom! It’s all good!

 

Someone was saying that it was because we charge the phone using our laptop via data cable.  Yes! I do that but not sure if that’s true..

 

Update: 23rd Nov 2015

My mom uses Walton phone and her phone had the same problem and I solved the problem with the same solution. And she doesn’t charges her phone with laptops.

Update on 11th July 2016 (adding a poll)

Was this fix helpful?
Yes
78 Vote
No
160 Vote